Glance Service Interruption - 12/4/2025

Incident Report for Glance Networks, Inc.

Resolved

This incident has been resolved.
Posted Dec 04, 2025 - 12:01 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 04, 2025 - 11:12 EST

Identified

We have identified an issue related to the release this morning and are in the process of rolling it back.
Posted Dec 04, 2025 - 10:53 EST

Investigating

The Glance Service experienced an interruption on 12/4/2025
Posted Dec 04, 2025 - 10:30 EST
This incident affected: www.GLANCE.net.