Glance Service Degradation - 10/20/25

Incident Report for Glance Networks, Inc.

Resolved

Our cloud provider has confirmed that the underlying issue has been resolved. Glance health metrics have shown consistent improvement, and all services are now operating normally.

Users should no longer experience issues initiating or maintaining Glance sessions.

We’ll continue to monitor performance closely to ensure stability.

— The Glance Team
Posted Oct 20, 2025 - 19:53 EDT

Identified

We’re currently investigating a service degradation caused by an upstream issue with our public cloud provider. Our engineering team is working closely with them to resolve this as quickly as possible.

No ETA is available yet. We’ll provide updates every hour or sooner as we learn more.
Posted Oct 20, 2025 - 09:52 EDT
This incident affected: www.GLANCE.net and Presence.