Glance Presence Service Interruption - 02/25/2025

Incident Report for Glance Networks, Inc.

Resolved

This incident has been resolved.
Posted Feb 25, 2025 - 14:52 EST

Identified

The Glance Presence Service experienced an interruption on 02/25/2025
Posted Feb 25, 2025 - 13:42 EST
This incident affected: Presence.